Android 14 est prêt à bloquer l’installation de certaines applications obsolètes

advertisment

Pour aider à réduire le potentiel de logiciels malveillants, Android 14 commencera à bloquer complètement l’installation d’applications qui ciblent des versions obsolètes d’Android.

advertisment

Depuis des années, les directives du Google Play Store garantissent que les développeurs Android maintiennent leurs applications à jour pour utiliser les dernières fonctionnalités et mesures de sécurité de la plate-forme Android. Ce mois-ci seulement, les directives ont été mises à jour, exigeant que les applications Play Store nouvellement répertoriées ciblent au minimum Android 12.

Jusqu’à présent, ces exigences minimales au niveau de l’API ne s’appliquaient qu’aux applications destinées au Google Play Store. Si un développeur souhaite créer une application pour une version plus ancienne, il peut le faire et demander simplement à ses utilisateurs de charger manuellement le fichier APK. De même, si une application Android n’a pas été mise à jour depuis la modification des directives, le Play Store continuera à proposer l’application à ceux qui l’ont déjà installée.

Selon un changement de code récemment publié, Android 14 est configuré pour rendre les exigences de l’API plus strictes, bloquant entièrement l’installation d’applications obsolètes. Cette modification empêcherait les utilisateurs de télécharger des fichiers APK spécifiques et empêcherait également les magasins d’applications d’installer ces mêmes applications.

Initialement, les appareils Android 14 ne bloqueront que les applications qui ciblent particulièrement les anciennes versions d’Android. Au fil du temps cependant, le plan est d’augmenter le seuil d’Android 6.0 (Marshmallow), Google ayant un mécanisme pour “augmenter progressivement [it] en haut.” Cela dit, il appartiendra probablement à chaque fabricant d’appareils de décider du seuil pour les applications obsolètes ou de l’activer.

Si l’application de la version minimale du SDK installable est activée, bloquez l’installation des applications à l’aide d’une version du SDK cible inférieure à celle requise. Cela permet d’améliorer la sécurité et la confidentialité, car les logiciels malveillants peuvent cibler les anciennes versions du SDK pour éviter l’application d’un nouveau comportement d’API.

En bloquant ces applications obsolètes, Google entend freiner la propagation des applications malveillantes sur Android. Le développeur responsable du changement note que certaines applications malveillantes ont intentionnellement ciblé les anciennes versions d’Android pour contourner certaines protections appliquées uniquement sur les nouvelles applications.

Cela dit, si pour une raison quelconque vous souhaitez ou avez besoin d’installer une application obsolète, cela sera toujours possible via un shell de commande, en utilisant un nouveau drapeau. Compte tenu des étapes supplémentaires requises, il est moins probable que quelqu’un le fasse par erreur et installe par inadvertance des logiciels malveillants.

En savoir plus sur Android 14 :

FTC : Nous utilisons des liens d’affiliation automatique générateurs de revenus. Suite.


Découvrez 9to5Google sur YouTube pour plus d’informations :

advertisment

Leave a Comment